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Введение 

Все возрастающие темпы урбанизации ставят вопросы мониторинга 

окружающей среды и улучшения экологической обстановки городов в ряд 

актуальных задач современности. Оптимизировать и особенно 

стабилизировать городскую среду возможно путем поддержания в хорошем 

состоянии зеленых насаждений – парков, скверов, бульваров и т.д. 

Растения под воздействием изменяющейся окружающей среды меняют 

свои характеристики. Количественный анализ таких изменений может давать 

представление не только о жизненном состоянии организма, но и об 

изменениях среды, в том числе под воздействием антропогенных факторов. В 

экологии активно развиваются методы биоиндикации, когда наблюдают за 

изменениями характеристик организмов и по их уровню судят о 

естественных или антропогенных изменениях в окружающей среде. С 

помощью современных методов фитоиндикации возможно отбирать 

наиболее устойчивые к городской среде виды растений или использовать их 

различные биолого-физиологические характеристики в качестве 

эффективных биоиндикаторов. 

Одним из таких широко применяемых методов является определение 

асимметрии органов растений или животных. Флуктуирующая асимметрия 

представляет собой незначительные ненаправленные отличия в проявлении 

признаков на симметричных сторонах биологического объекта. Число 

публикаций и исследований, в которых показано изменение величины 

асимметрии в ответ на повреждающее воздействие антропогенной среды 

достаточно велико. Однако, как отмечает ряд авторов, не зная природного 

проявления асимметрии трудно говорить о ее поведении в экстремальных 

условиях. Для этого необходимо тщательно подбирать объекты для 

использования метода флуктуирующей асимметрии среди растений, т.к. у 
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многих видов деревьев или кустарников отмечается естественная, 

характерная для вида асимметрия листьев.  

Для расчета флуктуирующей асимметрии используются измерения 

геометрических характеристик растений и дальнейшие вычисления 

признаков по заданным формулам. При большом числе измеряемых объектов 

такая задача становиться достаточно трудоемкой. Целью настоящего учебно-

методического пособия является знакомство с автоматизированным методом 

оценки флуктуирующей асимметрии листьев растений на основе 

использования программы ImageJ [1].  

1. Морфометрические параметры листьев  

Состояние биологической системы (клетки, органа или организма в 

целом) в той или иной степени характеризует воздействие на неё природных 

или антропогенных факторов и условий среды и может применяться для их 

оценки. Биоиндикаторы (от био и лат. indico – указываю, определяю) – 

организмы, присутствие, количество или особенности развития которых 

служат показателями естественных процессов, условий или антропогенных 

изменений среды обитания. Морфометрический подход основан на анализе 

морфологии листа, его формы, характерной для того или иного вида 

растения. Морфометрические показатели растения и его органов могут 

варьировать в зависимости от расстояния до источника загрязнения. 

Наиболее чувствительным органом растений является лист, который 

находится под прямым воздействием токсичных газов.  

В используемом морфогенетическом подходе оценивается стабильность 

развития листа. Любой лист (простой или сложный) состоит из основания 

листа, которым он крепится к стеблю, черешка и листовой пластинки, в 

которой выделяют основание листовой пластинки, кончик и край листовой 

пластинки. Как правило, листья обладают билатеральной симметрией по 

центральной жилке. Снижение эффективности и стабильности развития 

органа приводит к появлению отклонений от нормального строения 
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различных морфологических признаков, обусловленных нарушениями 

развития в условиях загрязнения.  

Количественные значения параметров листа находятся в прямой 

зависимости от уровня загрязнения окружающей среды: чем выше 

загазованность, тем больше меняются морфометрические признаки. 

Анализируют такие морфометрические параметры листьев как площадь, 

периметр, ширина или длина листовой пластинки, длина жилок, угол наклона 

жилок к центральной жилке, расстояния между жилками, расстояние между 

лопастями по краю листа и т.п. На основе измеренных значений параметров 

листа рассчитывают уровень флуктуирующей асимметрии листа, который 

дает представление о стабильности его развития [2]. 

2. Расчет флуктуирующей асимметрии листа  

Методика оценки состояния листьев на основе расчета их 

флуктуирующей асимметрии описана в работе В.М. Захарова [2]. 

Неблагоприятные воздействия различного типа вызывают в живых 

организмах изменения стабильности развития, о которых судят по 

показателям флуктуирующей асимметрии – различиям между значениями 

признаков правой и левой сторон различных морфологических структур, в 

норме обладающих симметрией. Такие различия обычно могут быть 

результатом негативного воздействия факторов окружающей среды в ходе 

развития организма, что и приводит к увеличению асимметрии органа.  

Оценка состояния листьев деревьев проводится на модельных 

площадках: 1) для фонового мониторинга используются несколько площадок 

в разных биотопах, различных по естественным условиям; 2) для оценки 

последствий антропогенного воздействия площадки выбираются из 

максимально сходных по естественным условиям биотопов, с различной 

степенью антропогенной нагрузки. Листья березы или других видов деревьев 

собираются с 5 (10) растений генеративного состояния, берутся листья с 
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веточек 2-го года, на высоте вытянутой руки в различных местообитаниях 

(зеленые насаждения города и эталонный участок за городом) [3].  

Оценка стабильности развития листьев по различным признакам 

сводится к оценке асимметрии, т.е. к учету различий в значениях признака 

слева и справа. Как правило, для расчета асимметрии листьев выбирают пять 

признаков (рис. 2.1): 1 – правая и левая ширины половинок листа r1 и l1, 2 – 

правая и левая длины вторых жилок второго порядка от основания листа r2 и 

l2, 3 – правое и левое расстояния между основаниями первой и второй жилок 

второго порядка r3 и l3, 4 – правое и левое расстояние между концами этих 

жилок r4 и l4, 5 – правый и левый угол между центральной жилкой и второй 

от основания жилкой второго порядка r5 и l5. 

 

Рис. 2.1. Измеряемые признаки листа 

Описанные признаки листа измеряются тем или иным способом для 

собранных листьев. На основе значений измеренных признаков производят 

вычисления относительных величин асимметрии. В первом действии для 

каждого измеренного листа вычисляются относительные величины 

асимметрии 𝑧𝑖  для каждого признака по формуле (i – номер признака) 

                                                   𝑧𝑖 =
(𝑙𝑖−𝑟𝑖)

(𝑙𝑖+𝑟𝑖)
                                                (2.1) 
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Полученные данные заносят в таблицу по каждому признаку. Далее 

вычисляют суммарный показатель асимметрии aj (j – номер листа) для 

каждого листа по 5 признакам. Для этого суммируют значения 

относительных величин асимметрии по каждому признаку и делят на число 

признаков (в данном случае признаков 5) 

𝑎𝑗 =
(𝑧1+𝑧2+𝑧3+𝑧4+𝑧5)

5
                                           (2.2) 

Полученный показатель 𝑎𝑗 называется величиной асимметрии 𝑗 – го 

листа. Далее вычисляется интегральный показатель стабильности развития – 

величина среднего относительного различия между сторонами на признак. 

Для этого вычисляют среднюю арифметическую 𝑎 всех величин асимметрии 

для каждого листа (минимум 10 листьев с одной особи, либо по 1 листу с 10 

особей):  

                                                      𝑎 =
∑ 𝑎𝑖

10
                                                      (2.3) 

Данные показатели «флуктуирующей асимметрии» листьев из 

различных мест сравнивают со значениями пятибалльной шкалы, 

разработанной В.М. Захаровым [4] (Табл. 2.1). Минимальный балл I 

соответствует условной норме. Максимальный балл V дает критическое 

значение «флуктуирующей асимметрии», которое наблюдается в случае, 

когда растение находится в крайне неблагоприятных условиях. 

Таблица 2.1.  

Балл Величина показателя 

стабильности развития 

Характеристика состояния 

окружающей среды 

I <0.040 чисто 

II 0.040-0.044 относительно чисто («норма») 

III 0.045-0.049 загрязнено («тревога») 

IV 0.050-0.054 грязно («опасно») 

V >0.054 очень грязно («вредно») 
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3. Краткое описание программы ImageJ 

Для автоматизации расчета асимметрии листьев удобно проводить 

измерения по изображениям листьев. Такие изображения могут быть 

получены с помощью фотографирования или сканирования поверхности 

листьев. Для работы с изображениями листьев может быть использована 

свободно распространяемая программа ImageJ [1]. Программа позволяет 

отображать, редактировать и анализировать изображения, сохраненные в 

различных форматах (TIFF, PNG, JPEG, BMP и других). Программа ImageJ 

активно используется в экологии, биологии, медицины и других областях для 

анализа изображений листьев, семян растений, снимков с микроскопов. 

ImageJ позволяет вычислять площади и периметры фигур на снимках, 

расстояния и углы, статистические показатели пиксельных значений 

различных выделенных областей на изображениях. ImageJ поддерживает 

стандартные функции обработки изображений: логические и арифметические 

операции с изображениями, повышение резкости, сглаживание, выделение 

границ и т.п. Программа позволяет производить различные геометрические 

преобразования с изображениями: масштабирование, поворот или отражение.  

Следуя учебному пособию [5], остановимся на кратком описании 

базовых функций программы ImageJ. Запуск программы осуществляется 

двойным нажатием на иконку программы на рабочем столе. В результате на 

экране появляется панель управления программы (рис. 3.1) [5]. 

 

 
Рис. 3.1. Панель управления программы ImageJ [5] 

 

https://ru.wikipedia.org/wiki/TIFF
https://ru.wikipedia.org/wiki/PNG
https://ru.wikipedia.org/wiki/JPEG
https://ru.wikipedia.org/wiki/BMP
https://ru.wikipedia.org/wiki/%D0%A1%D0%B3%D0%BB%D0%B0%D0%B6%D0%B8%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5
https://ru.wikipedia.org/wiki/%D0%90%D1%84%D1%84%D0%B8%D0%BD%D0%BD%D0%BE%D0%B5_%D0%BF%D1%80%D0%B5%D0%BE%D0%B1%D1%80%D0%B0%D0%B7%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5
https://ru.wikipedia.org/wiki/%D0%90%D1%84%D1%84%D0%B8%D0%BD%D0%BD%D0%BE%D0%B5_%D0%BF%D1%80%D0%B5%D0%BE%D0%B1%D1%80%D0%B0%D0%B7%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5
https://ru.wikipedia.org/wiki/%D0%9C%D0%B0%D1%81%D1%88%D1%82%D0%B0%D0%B1%D0%B8%D1%80%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D0%B5
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Рис. 3.2. Развернутая панель программы ImageJ [5] 

 

Подробная панель управления ImageJ с указанием функций клавиш 

основного меню приведена на рис. 3.2 [5]. Приведем описание функций 

основного меню. 

1. Четыре клавиши меню для выделения областей различной формы: 

прямоугольник, овал, полигон или «выделение от руки». После выделения 

некоторой области на изображении ее можно копировать, изменять, 

анализировать при помощи команд меню и т.д. При выделении координаты 

положения курсора отображаются ниже в строке состояния.  

2. Инструмент выделения линий используется для создания прямой линии, 

сегментированных линий или «линии от руки». Чтобы выбрать тип линии, 

нужно щелкнуть по кнопке правой кнопкой мыши. Координаты положения 

курсора на рисуемой линии также отображаются в строке состояния. 

Изменить толщину линии можно двойным нажатием на кнопку.  

3. Инструмент измерения углов рисует поочередно 2 линии, которые 

образуют угол, и сохраняет величину данного угла.  
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4. С помощью инструмента выделения точек можно отметить различные 

точки на изображении. При этом координаты отмеченной точки (x, y) и 

значения яркости (от 0 до 255) отображаются в строке состояния. Для 

цветного изображения даются значения яркости трех цветов: красного, 

зеленого и синего. Для монохромного изображения в строке состояния 

появляется только одно значение. Чтобы отметить сразу несколько точек, 

следует нажать и удерживать клавишу Shift или Alt. При выполнении 

команды Analyze>Measure (Ctrl+M), координаты и значения каждой точки 

выводятся в файл Result, который можно сохранить или распечатать.  

5. Инструмент «Волшебная палочка» используется для автоматического 

определения краев объекта на изображении, т.е. выделяется граница объекта. 

Точность выделения границ зависит от контрастности изображения. 

Качественное выделение границ обеспечивается для высококонтрастных 

объектов. Выбор команды Threshold через цепочку меню 

Image>Adjust>Threshold позволяет изменить контрастность изображения. 

Команда Threshold работает только с черно-белыми изображениями, поэтому 

перед ее применением следует выбрать цепочку меню Image>Type>8-bit. 

Выбрав точку на объекте с помощью “волшебной палочки”, будем отмечать 

точки вдоль объекта. В результате появится выделение по линии смены 

контраста на изображении.  

6. При выборе инструмента для работы с текстом и выделении точки на 

изображении появится область для введения текста. Чтобы зафиксировать 

этот текст на изображении нужно нажать Edit>Draw (или Ctrl+D).  

7. При выборе инструмента «Увеличительное стекло» при нажатии левой 

кнопки мыши изображение будет увеличиваться, а при нажатии правой 

кнопкой – уменьшаться.  

8. Инструмент «Прокрутка» позволяет просмотреть изображение, которое не 

помещается в одно окно.  
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9. Инструмент «Выбор цвета» позволяет выбрать цвет линий или текста. С 

помощью него, как с помощью пипетки, можно выбрать цвет с любой части 

изображения. Также можно изменить цвет этого инструмента 

Image>Color>Color Picker (либо просто двойным кликом на кнопку 

инструмента). Значок для этого инструмента показывает текущий цвет 

текста, а рамка вокруг показывает цвет фона.  

10. Инструмент выхода из макроса или плагина (клавиша – ESC).  

11. Инструменты для работы со стеками и таблицами. При нажатии на эти 

кнопки отображается меню, содержащее команды для работы с 

вышеописанными элементами.  

12. Инструменты для рисования – карандаш, кисть, заливка, стрелочка. По 

щелчку на эти кнопки можно установить толщину карандаша, стрелочки или 

кисти, или метод заливки.  

13. Инструменты для работы с макросами и плагинами.  

4. Метод расчета флуктуирующей асимметрии листьев с помощью измерений 

в программе ImageJ 

Для начала работы необходимо запустить программу ImageJ и открыть 

файл со снимком листа. После запуска программы на рабочем столе 

появляется панель управления ImageJ. Далее в строке меню выбираем 

File>Open и открываем изображение листа, которое находится в рабочей 

директории (рис. 4.1). 
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Рис. 4.1. Загрузка изображения листа 

После того, как изображение листа открылось, необходимо задать 

линейный масштаб длины. Изображения листьев должны включать в себя 

образец отрезка или квадрата с заданным размером в одну единицу 

измерения длины, например, один сантиметр. Для задания масштаба длины 

на панели управления выбираем инструмент выделения линий и проводим 

прямую линию в пределах заданного образца отрезка или квадрата. Для 

изображения листа на фоне квадратной сетки проводим линию длиной 1 см в 

пределах двух клеток (рис. 4.2). Далее устанавливаем масштаб длины с 

помощью цепочки меню: Analyze>Set Scale. В появившемся окне Set Scale в 

пункте Distance in pixels появляется длина проведенного отрезка в пикселях. 

В пункте Unit of length выбираем единицу измерения, в данном случае cm 

(рис. 4.3) 
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Рис. 4.2. Определение линейного масштаба изображения 

 

 

Рис. 4.3. Выбор масштаба длины 
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Выбор опорных точек на листе начнем с определения положения центра 

главной жилки. Для этого на панели управления выбираем инструмент 

выделения линий и проводим линию, соединяющую крайние точки листа 

(рис. 4.4). Программа автоматически находит центр проведенной линии. 

Затем проводим горизонтальную линию по предварительно найденному 

центру главной жилки (рис. 4.5). 

 

Рис. 4.4. Выделение отрезка, связывающего крайние точки листа вдоль 

основной жилки 

 

Рис. 4.5. Выделение срединного отрезка 
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Т.к. проведенная горизонтальная линия необходима нам для поиска 

ширин половинок листа, ее необходимо сохранить на изображении. Для 

этого в строке меню выбираем Edit>Draw (рис.4.6). 

 

Рис. 4.6. Сохранение горизонтальной линии 

Для расчета значений признаков листа введем набор опорных точек на листе 

(рис. 4.7): 

x1.y1 – основание главной жилки; 

x2.y2 – конец главной жилки; 

x3.y3 – основание правой жилки первого порядка; 

x4.y4 – конец правой жилки первого порядка; 

x5.y5 – основание левой жилки первого порядка; 

x6.y6 – конец левой жилки первого порядка; 

x7.y7 – основание правой жилки второго порядка; 

x8.y8 – конец правой жилки второго порядка; 

x9.y9 – основание левой жилки второго порядка; 

x10.y10 – конец левой жилки второго порядка; 

x11.y11– вспомогательная точка на главной жилке для построения угла; 



17 
 

x12.y12 – вспомогательная точка на правой жилке второго порядка для 

построения угла; 

x13.y13 – вспомогательная точка на левой жилке второго порядка для 

построения угла; 

x14.y14 – вспомогательная точка для поиска ширины правой половинки листа; 

x15.y15 – вспомогательная точка для поиска ширины левой половинки листа; 

x16.y16 – центр главной жилки. 

Далее на панели управления выбираем инструмент точка. Левой кнопкой 

мыши выбираем Multi-point Tool и отмечаем 16 опорных точек (рис. 4.7) в 

строго заданном выше порядке. Точки x14 и x15 отмечаем на концах 

горизонтальной линии (рис.4.8). 

 

 

Рис. 4.7. Схема выделяемых опорных точек листа 
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Рис. 4.8. Выделение опорных точек на листе 

Для сохранения полученных координат опорных точек выбираем цепочку в 

меню: File>Save As>XY Coordinates. Задаем имя файлу и сохраняем его в 

заранее созданной папке (рис. 4.9) в формате блокнота (рис. 4.10). 

 

Рис. 4.9. Сохранение координат опорных точек 
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Рис. 4.10. Пример содержания файла с координатами опорных точек 

5. Формулы расчета флуктуирующей асимметрии через координаты опорных 

точек 

На основе сохраненных в файле значений координат опорных точек 

вычисляем флуктуирующую асимметрию листа. Приведем формулы расчета 

флуктуирующей асимметрии через координаты опорных точек. 

Ширины правой 𝑟1  и левой 𝑙1 половинок листа: 

𝑟1 = √(𝑥16 − 𝑥14)2 + (𝑦16 − 𝑦14)2,                   (5.1) 

𝑙1 = √(𝑥16 − 𝑥15)2 + (𝑦16 − 𝑦15)2.                    (5.2) 

Длины правой 𝑟2 и левой 𝑙2  жилок второго порядка: 

𝑟2 = √(𝑥7 − 𝑥8)2 + (𝑦7 − 𝑦8)2.                         (5.3) 

 𝑙2 = √(𝑥9 − 𝑥10)2 + (𝑦9 − 𝑦10)2.                             (5.4) 

Расстояния между основаниями первой и второй жилок второго порядка: 

𝑟3 = √(𝑥3 − 𝑥7)2 + (𝑦3 − 𝑦7)2.,                                   (5.5) 

𝑙3 = √(𝑥5 − 𝑥9)2 + (𝑦5 − 𝑦9)2.                                       (5.6) 

Расстояния между концами первой и второй жилок второго порядка:
 

𝑟4 = √(𝑥4 − 𝑥8)2 + (𝑦4 − 𝑦8)2.                                     (5.7) 
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𝑙4 = √(𝑥6 − 𝑥10)2 + (𝑦6 − 𝑦10)2;                                    (5.8) 

Углы 𝑟5 , 𝑙5  между главной жилкой и второй от основания жилкой второго 

порядка: 

                   𝑟5 = arccos (
𝑎1𝑥×𝑎2𝑥+𝑎1𝑦×𝑎2𝑦

√𝑎1𝑥
2+𝑎1𝑦

2×√𝑎2𝑥
2+𝑎2𝑦

2
)                                             (5.9) 

𝑎1𝑥 = 𝑥11 − 𝑥7.   𝑎1𝑦 = 𝑦11 − 𝑦7. 𝑎2𝑥 = 𝑥12 − 𝑥7. 𝑎2𝑦 = 𝑦12 − 𝑦7              

           𝑙5 = arccos (
𝑎3𝑥×𝑎4𝑥+𝑎3𝑦×𝑎3𝑦

√𝑎3𝑥
2+𝑎3𝑦

2×√𝑎4𝑥
2+𝑎4𝑦

2
)                                       (5.10) 

𝑎3𝑥 = 𝑥11 − 𝑥9. 𝑎3𝑦 = 𝑦11 − 𝑦9. 𝑎4𝑥 = 𝑥13 − 𝑥9. 𝑎4𝑦 = 𝑦13 − 𝑦9 

Показатель асимметрии для каждого листа по 5 признакам вычисляется по 

формулам: 

                                      𝑎 = |
(𝑧1+𝑧2+𝑧3+𝑧4+𝑧5)

5
|                           (5.11) 

𝑧1 = |
(𝑟1−𝑙1)

(𝑟1+𝑟1)
|  ,   𝑧2 = |

(𝑟2−𝑙2)

(𝑟2+𝑟2)
|  , 𝑧3 = |

(𝑟3−𝑙3)

(𝑟3+𝑟3)
|,    𝑧4 = |

(𝑟4−𝑙4)

(𝑟4+𝑟4)
|, 𝑧5 = |

(𝑟5−𝑙5)

(𝑟5+𝑟5)
| . 

 

6. Расчет флуктуирующей асимметрии в программах Leaf_1 и Leaf_10 

 Программы Leaf_1 и Leaf_10 предназначены для расчета 

флуктуирующей асимметрии по данным с одного листа и с 10 листьев 

одновременно (рис. 6.1). Программы Leaf_1 и Leaf_10 доступны на сайте 

Института экологии и природопользования КФУ. 

 
Рис. 6.1. Папки с программами Leaf_1 и Leaf_10 
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Для осуществления расчетов необходимо, чтобы данные с координатами 

и программа находились в одной директории. В данном примере в документе 

leaf_1.dat находятся 16 пар координат точек одного листа (рис. 6.2). 

 

Рис. 6.2. Директория leaf_1 расчета 

Запустим на выполнение программу leaf_1.exe двойным нажатием левой 

кнопки мыши (рис. 6.2). В результате выполнения программы сформируется 

файл с расчетными данными leaf_assym.dat (рис. 6.3), в котором содержится 

значение асимметрии листа. 

 

Рис. 6.3. Директория leaf_1 после расчета 

Для расчета асимметрии десяти листов формируется файл с 

координатами опорных точек десяти листьев и используется программа 

leaf_10.exe.  

7. Расчет площади и периметра листа в программе ImageJ 

Для расчета площади листа необходимо задать реальный масштаб 

(описано выше). После введения масштаба изображения, преобразуем в 8-bit 

изображение: Image>Type>8-bit (рис. 7.1). 
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Рис. 7.1. 8-bit изображение 

Далее необходимо отредактировать изображение по цветам, т. е. 

разделить его на два контрастных цвета: Image>Adjust>Threshold 

(рис. 7.2). 

 

 

Рис. 7.3. Редактирование изображения по цветам 
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Затем выбираем Analyze>Set Measurements и рассчитываемые величины 

площадь Area и периметр Perimeter листа (рис. 7.4). 

 

Рис. 7.4. Выбор расчета площади Area и периметра Perimeter листа 

Для того, чтобы вывести результат на клавиатуре необходимо нажать 

клавишу с буквой M (рис. 7.5). 

 

Рис. 7.5. Вывод результата на экран 
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